GUINEVERE - INSTALL THE VIEWER

The GUINEVERE Virtual World is located on a server somewhere in Europe and a special viewer needs to be installed on your computer in order connect to this 'virtual world' server. It is the only software that needs to be installed on the computer(s).

The best way to check if a computer can run the viewer is to install the software and see if it runs. It might show an error about the video card but still work fine.

There are several viewers to connect to the Virtual World, but we recommend the Firestorm viewer.

Download the Firestorm viewer (choose the 'SL& Opensim 64-bit or 32-bit')

The following video explains how to download & install the Firestorm viewer.

The following video explains how to set up the Firestorm viewer.

Note: Firestorm is compatible with Windows 10. However, if you are running Windows 10 on a system with an older Intel graphics card which does not support Windows 10 - Intel HD 2000, Intel HD 3000 or anything marked as “No” for Windows 10 on this list, you will only be able to run the 32bit versions of Firestorm even if you have a 64bit version of Windows 10. Please see this page for detailed instructions if you are running Windows 10 on an older unsupported Intel card and have problems running Firestorm.